Can someone please help with vmware workspace? its crashing with connection error every time

Hey guys, super new to the scene here and trying to get my berrings. Finding out I may have been overconfident and installed Kali too early because I’ve had errors that I’ve had to work through on almost every installation (including linux itself), but have been working through each problem in good time with a quick web search. This is the first thing I’ve gotten truly stuck on, so forgive me for lacking some technical terms etc.

 I downloaded Workstation (free) and also installed metasploit 2. Unzipped and tried to run with the vmx file as instructed, and as it said "connecting", all of a sudden it just said 'error' super fast and Workstation crashed. I tried multiple times, then re-installed metasploit. Also tried downloading an SSH shell but the guide to downloading an SSH led me to a non-working command. Tried to open a non metasploit virtualmachine as well, both crash immediately and dont even show me an error message now. As soon as I hit run it just crashed. Reinstalled Workstation, same issue occurring. Tried to run this: vmplayer /path/to/virtual machine

and got

failed to load external entity “/etc/vmware/hostd/proxy.xml”

vmplayer: Too many arguments; only one virtual machine can be specified at a time.

Try ‘vmplayer --help’ for more information.

How do I upload my logs?

Thanks in advance!

x-manlord