Linux Kung-Fu 01 CTF Challenge

Reserved for discussing Linux Kung-Fu 01 CTF challenge.

Hi all

Is someone else facing problems with the login?
I always get the message “broken pipe”

THX

Hi Fluxx, I just double checked and the connection seems fine from my side. Is it possible that you SSH session is getting interrupted for some reason? Give it another try and let me know how it goes.

Hi Tarek
I finally tried it with Putty and it works fine.
But if I ssh into the server using my kali, It doesn’t work.

Thx

Hi Tarek
I’m facing the problem that the flags I found are not accepteded by the system.
I found 2 flags but none of them is accepted.

Please don’t hesitate to contact me directly for such issues. Send me the details and I’ll be more than happy to investigate the issues further & fix things up if it’s an actual issue with the flags or the platform.
Anyhow, since your problem is with the Linux Kung-fu challenges, I think I know what it is. You’re basically overlooking the details, and you’re solving challenges that aren’t showing on the CTF dashboard YET. Just Don’t move out of the home directory the you SSH-ed into

Hi Rami
I tried to send you an eMail but it didn’t worked.

Is there an issue with your address?

Hello again
I just don’t get it. I can’t find anything helpful in the home directory.

Really KEEP looking!!! Its there and the Dev was not joking when they said stay where you are!!
I am good with shell and it took me a few min to notice!
Inspect everything!
Good Luck.

2 Likes

Finally I managed it get that flag!
I really spend sooooo much time on it. It‘s really inconspicuous.

Thx a lot @SpoonZ for your hint.

3 Likes

I like the persistence :smiley:

1 Like

No worries mate… took me a few min lol…

Yerr you got Web005 i been looking at that today and noticed a few things…

There is a vuln with the php session cookie and also xss protection is off… Is this a cookie grab and simple sqli hit?

My bad, it’s “.ae” not “.com”

Hi mates…

There is some trick/joke on Kung-Fu 01??

The flag is not the flag? hahaha

1 Like

Hey leooel,

So it could be that you found the flag for another challenge by accident :slight_smile: Try submitting the flag you found for one of the other challenges.

Have fun!

1 Like